
  



<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.waltontribune.com/content/tncms/live/" />
<meta name="keywords" content="obituaries" />
<meta name="news_keywords" content="obituaries" />
<meta name="description" content="James McKendree Wall, 92, of Elmhurst, Illinois, died Monday, March 22, 2021." />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.waltontribune.com/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/7/e5/7e58a104-9100-11eb-b072-7f4b8c7b3894/60628f79dd12e.preview.jpg?resize=1200%2C628" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="628" />
<meta property="og:title" content="James McKendree Wall" />
<meta property="og:description" content="James McKendree Wall, 92, of Elmhurst, Illinois, died Monday, March 22, 2021." />
<meta property="og:site_name" content="WaltonTribune.com" />
<meta property="og:section" content="Obituaries" />
<meta property="fb:app_id" content="139052946138066" />
<meta property="article:publisher" content="https://www.facebook.com/waltontribune/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@waltontribune" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.c82aec58b25786d9065c7ecf4b19c25f.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.0740431ec2aa31f2e7d813ea5c660a8d.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-classifieds-bulletins.a78f8be1f6e0dabcb5acb9a8939501f8.css"/>
<style>/*<![CDATA[*/ #user-controls-1801220 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1801220 .tn-user-screenname, #user-controls-1801220 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1801220 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1801220 .dropdown-signup { font-size: 12px; } #user-controls-1801220 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1801220 .large-user-avatar { margin-right: 10px; } #user-controls-1801220 .large-user-controls { font-size: 12px; } #user-controls-1801220 .logout-btn { cursor: pointer; } #user-controls-1801220 .login-btn { color: #fff!important; } .follow-links-1801218 li { margin-right: 1px; padding: 0; } .follow-links-1801218 li a, .follow-links-1801218 li a:focus, .follow-links-1801218 li a:active { ; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-1801218 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1801218 li a.fb,.follow-links-1801218 li a.fb:hover { color: #3A59A5; } .follow-links-1801218 li a.tw,.follow-links-1801218 li a.tw:hover { color: #46C8F9; } .follow-links-1801218 li a.yt,.follow-links-1801218 li a.yt:hover { color: #CE2B29; } .follow-links-1801218 li a.is,.follow-links-1801218 li a.is:hover { color: #D4C4A2; } #weather-1801222 .list-unstyled { margin: 0; } #weather-1801222 span { display: block; } #weather-1801222 .forecast-link a { padding: 8px; margin-top: -10px; } #weather-1801222 .icon { position: relative; } #weather-1801222 .icon .tnt-svg { position: relative; font-size: 26px; margin-bottom: -6px; margin-right: 8px; margin-top: -8px; } #weather-1801222 .temp { font-size: 18px; line-height: 20px; font-weight: bold; } #weather-1801222 .cond { opacity: 0.7; } #weather-1801222 .current-conditions { float: left; height: 24px; } #weather-1801222 .dropdown-toggle { color: #49627b; display: block; } #site-top-nav #weather-1801222 .icon { margin-top: 4px; } #site-top-nav #weather-1801222 .temp { line-height: 36px; } #weather-1801222 .current-conditions { height: 36px; padding: 0 10px; } #main-navigation #weather-1801222 .current-conditions { padding-top: 11px; } #weather-1801222 .city-title { padding-top: 5px; } #weather-1801222 .weather-expanded { padding: 0 15px; width: 300px; font-weight: normal; } #weather-1801222 .weather-expanded h5 { border-top: 1px solid rgba(0,0,0,.05); padding-top: 10px; } #weather-1801222 .weather-expanded small { opacity: 0.5; } #weather-1801222 .zip-update-form { width: 140px; margin-top: -54px; background-color: #eee; padding: 5px; position: absolute; display: none; right: 0; } #weather-1801222 .zip-update { width: 75px; } #weather-1801222 .zip-update-link { color: #999; font-size: 18px; text-decoration: none; } #weather-1801222 .zip-update-link:hover { color: #777; } #tncms-block-1801177 .tnt-prop-img { max-width: 657px; } #site-logo-1801177 { color: #666; } #block-1801216 .search-spinner { position: absolute; } #block-1801216 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1801216 { margin-bottom: 0; } #site-search-1801216 .site-search-form { padding: 0; } #site-search-1801216 #site-search-1801216-btn { outline: none; } #site-search-1801216 #site-search-1801216-term { border: 0; box-shadow: none; } #site-search-1801216 .site-search-form { box-shadow: none; } #tncms-block-1801213 .tnt-prop-img { max-width: 571px; } #site-logo-1801213 { color: #666; } #block-1801178 .most-popular .tab-text { display: none; } #block-1801178 .most-popular .active .tab-text { display: inline; } #block-1801139 .card.summary { border: 0; padding: 0; margin: 0; } #block-1801139 .card-panel { background-color: #f2f2f3; border-color: rgba(0,0,0,.08); } #block-1801209 .block-title .block-title-inner { background-color: #695c34; } #block-1801169 .block-title .block-title-inner { background-color: #695c34; } #block-1801211 .block-title .block-title-inner { background-color: #695c34; } .follow-links-1801219 li { margin-right: 1px; padding: 0; } .follow-links-1801219 li a, .follow-links-1801219 li a:focus, .follow-links-1801219 li a:active { ; height: 36px; width: 36px; font-size: 24px; color: #fff!important; border-radius: 0; opacity: .8; padding:0; box-shadow: none; } .follow-links-1801219 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1801219 li a.fb,.follow-links-1801219 li a.fb:hover { color: #fff; background-color: #3A59A5; } .follow-links-1801219 li a.tw,.follow-links-1801219 li a.tw:hover { color: #fff; background-color: #46C8F9; } .follow-links-1801219 li a.yt,.follow-links-1801219 li a.yt:hover { color: #fff; background-color: #CE2B29; } .follow-links-1801219 li a.is,.follow-links-1801219 li a.is:hover { color: #fff; background-color: #D4C4A2; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"mobile_pattern","style":"default","path":"\/obituaries","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":243},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"7e58a104-9100-11eb-b072-7f4b8c7b3894","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/14694/cc.js?ns=_cc14694" id="LOTCC_14694"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc14694.add('tp', 'TNNW');
		_cc14694.add('act', ' User Login');
		_cc14694.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc14694.bcp();
</script>

<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/ads/impressions.js?_dc=1617091529"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/ads/traffic.js?_dc=1617078929"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/ads/settings.js?_dc=1587045994"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/ads/fixed-big-ad-middle-asset/1.js?_dc=1614197726"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1614592900"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/ads/fixed-big-ad-middle/1.js?_dc=1614592900"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/ie.grid.placement.8d31e32afeebe4520bfab9638ef91435.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>James McKendree Wall | Obituaries | waltontribune.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #4175aa; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #ffffff; } .fixed-nav #main-navigation { background-color: #ffffff !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer-container, #site-footer { background-color: #817144; color: #f2f2f3; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #80000A; } .navbar-toggle .icon-bar { background-color: #80000A !important; } .navbar-toggle .sr-only-show { color: #80000A !important; } #site-top-nav .list-inline>li>a { color: #4175aa; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #80000A; } }#site-copyright a, #site-footer a { color: #f2f2f3; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.waltontribune.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/d3a0f48a-9729-11ea-93c0-6feac449d2b6.jpg?resize=180%2C180" />
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="James McKendree Wall | Obituaries | waltontribune.com" href="http://www.waltontribune.com/search/?f=rss&amp;t=article&amp;c=obituaries&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.waltontribune.com/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            
        </head>
        <body class="app-editorial grid-mobile-pattern blox-asset uuid-7e58a104-9100-11eb-b072-7f4b8c7b3894  section-obituaries type-article infinity-disabled" data-path="/obituaries">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.waltontribune.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=mobile_pattern&amp;tncms.page.style=default&amp;tncms.page.path=%2Fobituaries&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=blox&amp;tncms.system.render_time=243&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.asset.id=7e58a104-9100-11eb-b072-7f4b8c7b3894&amp;tncms.asset.app=editorial&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.waltontribune.com",
  secureDomain: "waltontribune.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.waltontribune.com/tncms/admin/editorial-asset/?edit=7e58a104-9100-11eb-b072-7f4b8c7b3894"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
    
    
    
    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-1801220" class="tncms-block"><div id="user-controls-1801220" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.waltontribune.com/users/signup/?referer_url=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.waltontribune.com/users/login/?referer_url=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.waltontribune.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1801220').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.waltontribune.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.waltontribune.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.waltontribune.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1801220').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.waltontribune.com/users/logout/" id="user-logout-form-1801220"><input type="hidden" name="referer_url" value="https://www.waltontribune.com/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1801218" class="tncms-block"><div class="follow-links-1801218 pull-right">
    
    <section id="block-1801218" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/waltontribune/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.twitter.com/waltontribune" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/user/TheTribunetube" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://instagram.com/thewaltontribune" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.waltontribune.com",
  "sameAs" : ["https://www.facebook.com/waltontribune/","https://www.twitter.com/waltontribune","https://www.youtube.com/user/TheTribunetube","https://instagram.com/thewaltontribune"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1801222" class="tncms-block"><div id="weather-1801222" class="weather-current size-small pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=30655" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc small">
                    <span class="temp">44&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="30655"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-1801222 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Monroe, GA
                                
                                 <small>(30655)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Sun and clouds mixed. High around 70F. Winds E at 5 to 10 mph..</p>
                            <h5>Tonight</h5>
                            <p>Overcast with showers at times. Low around 60F. Winds light and variable. Chance of rain 40%.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: March 30, 2021 @ 3:59 am</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=30655"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-1867909" class="tncms-block pull-left">
        <div id="blox-ad-position-section-sponsor1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"section-sponsor","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
    <div id="masthead-col-two" class="col-md-6 col-sm-6">
        <div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1801177" class="tncms-block"><div id="site-logo-1801177" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/bf974cc8-3158-11ea-b117-a383e58818ab.png?resize=200%2C50" 
            srcset="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/bf974cc8-3158-11ea-b117-a383e58818ab.png?resize=150%2C37 150w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/bf974cc8-3158-11ea-b117-a383e58818ab.png?resize=200%2C50 200w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/bf974cc8-3158-11ea-b117-a383e58818ab.png?resize=225%2C56 225w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/bf974cc8-3158-11ea-b117-a383e58818ab.png?resize=300%2C74 300w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/bf974cc8-3158-11ea-b117-a383e58818ab.png?resize=400%2C99 400w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/bf974cc8-3158-11ea-b117-a383e58818ab.png?resize=540%2C134 540w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/bf974cc8-3158-11ea-b117-a383e58818ab.png?resize=640%2C159 640w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/bf974cc8-3158-11ea-b117-a383e58818ab.png 750w"
            sizes="(min-width: 1200px) 570px, calc(50vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="657"
            height="163"
            alt="site-logo"></a>
        </div></div></div></div>
    </div>
    <div id="masthead-col-three" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1801216" class="tncms-block header-search"><section id="block-1801216" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1801216" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1801216" aria-labelledby="site-search-button-1801216" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal form-control">
        <input id="site-search-1801216-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1801216-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1801216-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1801216').submit();
        return false;
    });

    $('#site-search-1801216').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1801216 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1801216 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1801216-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-1818745" class="tncms-block">
        <div id="blox-ad-position-block-tile-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-tile-top","slot":"1","fold":"","width":"200","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                        <button  type="button" class="navbar-toggle" data-toggle="collapse" data-target="#navbar-collapse" aria-expanded="false">
                            <span class="visible-sm sr-only-show">Sections</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_dropdown">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1801213" class="tncms-block"><div id="site-logo-1801213" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/0eac317c-5c9f-11ea-95b6-ebec1e6216c5.png?resize=200%2C37" 
            srcset="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/0eac317c-5c9f-11ea-95b6-ebec1e6216c5.png?resize=150%2C28 150w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/0eac317c-5c9f-11ea-95b6-ebec1e6216c5.png?resize=200%2C37 200w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/0eac317c-5c9f-11ea-95b6-ebec1e6216c5.png?resize=225%2C42 225w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/0eac317c-5c9f-11ea-95b6-ebec1e6216c5.png?resize=300%2C56 300w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/0eac317c-5c9f-11ea-95b6-ebec1e6216c5.png?resize=400%2C74 400w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/0eac317c-5c9f-11ea-95b6-ebec1e6216c5.png?resize=540%2C100 540w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/custom/image/0eac317c-5c9f-11ea-95b6-ebec1e6216c5.png 640w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="571"
            height="106"
            alt="site-logo"></a>
        </div></div></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li class="dropdown" aria-expanded="false">
                <a class="nav-link  nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact_us"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-staff"  href="/site/staff"  tabindex="0">
                    <span class="nav-label">Staff</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-news"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-opinions"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinions</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-letters-to-the-editor"  href="/opinion/letters_to_editor/"  tabindex="0">
                    <span class="nav-label">Letters To The Editor</span>
                </a></li><li>
                <a class="nav-link   tnt-section-editorials"  href="/opinion/editorials/"  tabindex="0">
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link   tnt-section-columns"  href="/opinion/columns/"  tabindex="0">
                    <span class="nav-label">Columns</span>
                </a></li><li>
                <a class="nav-link   tnt-section-write-to-us"  href="/site/forms/online_services/submit_news/"  tabindex="0">
                    <span class="nav-label">Write to Us</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-lifestyles"  href="/lifestyles/"  tabindex="0">
                    <span class="nav-label">Lifestyles</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-education"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/education/"  tabindex="0">
                    <span class="nav-label">Education</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-walton-county-school-district"  href="/education/walton_county_public_schools/"  tabindex="0">
                    <span class="nav-label">Walton County School District</span>
                </a></li><li>
                <a class="nav-link   tnt-section-social-circle-city-schools"  href="/education/social_circle_city_schools/"  tabindex="0">
                    <span class="nav-label">Social Circle City Schools</span>
                </a></li><li>
                <a class="nav-link   tnt-section-private-academies"  href="/education/private_academies/"  tabindex="0">
                    <span class="nav-label">Private Academies</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-communities"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/communities/"  tabindex="0">
                    <span class="nav-label">Communities</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-monroe"  href="/communities/monroe/"  tabindex="0">
                    <span class="nav-label">Monroe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-loganville-tribune"  href="/loganville/"  tabindex="0">
                    <span class="nav-label">Loganville Tribune</span>
                </a></li><li>
                <a class="nav-link   tnt-section-social-circle"  href="/communities/social_circle/"  tabindex="0">
                    <span class="nav-label">Social Circle</span>
                </a></li><li>
                <a class="nav-link   tnt-section-walnut-grove"  href="/communities/walnut_grove/"  tabindex="0">
                    <span class="nav-label">Walnut Grove</span>
                </a></li><li>
                <a class="nav-link   tnt-section-good-hope"  href="/communities/good_hope/"  tabindex="0">
                    <span class="nav-label">Good Hope</span>
                </a></li><li>
                <a class="nav-link   tnt-section-between"  href="/communities/between/"  tabindex="0">
                    <span class="nav-label">Between</span>
                </a></li><li>
                <a class="nav-link   tnt-section-jersey"  href="/communities/jersey/"  tabindex="0">
                    <span class="nav-label">Jersey</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-announcements"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/announcements/"  tabindex="0">
                    <span class="nav-label">Announcements</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-weddings"  href="/announcements/weddings/"  tabindex="0">
                    <span class="nav-label">Weddings</span>
                </a></li><li>
                <a class="nav-link   tnt-section-engagements"  href="/announcements/engagements/"  tabindex="0">
                    <span class="nav-label">Engagements</span>
                </a></li><li>
                <a class="nav-link   tnt-section-anniversary"  href="/announcements/anniversary/"  tabindex="0">
                    <span class="nav-label">Anniversary</span>
                </a></li><li>
                <a class="nav-link   tnt-section-births"  href="/announcements/births/"  tabindex="0">
                    <span class="nav-label">Births</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition/"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-11" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-jobs"  href="/jobs/"  tabindex="0">
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-link   tnt-section-real-estate"  href="/homes/"  tabindex="0">
                    <span class="nav-label">Real Estate</span>
                </a></li><li>
                <a class="nav-link   tnt-section-autos"  href="/autos/"  tabindex="0">
                    <span class="nav-label">Autos</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-an-ad"  href="/site/forms/online_services/classified/"  tabindex="0">
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business-directory"  href="/business_directory/"  tabindex="0">
                    <span class="nav-label">Business Directory</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-circulation"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">Circulation</span>
                </a><ul id="main-nav_menu-child-12" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services/subscribe/"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-report-a-problem"  href="/site/forms/subscription_services/deliveryissue/"  tabindex="0">
                    <span class="nav-label">Report a Problem</span>
                </a></li><li>
                <a class="nav-link   tnt-section-enter-a-vacation-stop"  href="/site/forms/subscription_services/vacation/"  tabindex="0">
                    <span class="nav-label">Enter a Vacation Stop</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1801118" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1801119" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-7e58a104-9100-11eb-b072-7f4b8c7b3894" class="asset article-default"  data-url="https://www.waltontribune.com/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/7/e5/7e58a104-9100-11eb-b072-7f4b8c7b3894/60628f79dd12e.preview.jpg?resize=1200%2C628">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="628">
        </div>
        <meta itemprop="name" content="waltontribune.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.waltontribune.com/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html" />
    <div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":true,"nextUrl":"https:\/\/www.waltontribune.com\/tncms\/search\/mlt\/?origin=7e58a104-9100-11eb-b072-7f4b8c7b3894&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-7e58a104-9100-11eb-b072-7f4b8c7b3894" class="asset-paging">
                <div id="paging-prev-7e58a104-9100-11eb-b072-7f4b8c7b3894" class="paging-link prev offset"></div>
                <div id="paging-next-7e58a104-9100-11eb-b072-7f4b8c7b3894" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <div class="kicker lead text-muted">Obituary | 1928–2021</div><h1 itemprop="headline" class="headline">
        <span>
            
            James McKendree Wall
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2021-03-29T22:34:00-04:00" class="tnt-date asset-date text-muted">
            Mar 29, 2021
        </time></li>
            <li class="hidden-print"><time datetime="2021-03-29T22:34:00-04:00" class="tnt-date asset-date text-muted">Mar 29, 2021</time>
        <span class="text-muted tnt-update-recent">Updated </span>
        <time datetime="2021-03-29T22:40:12-04:00" class="tnt-date tnt-update-recent asset-date text-muted">5 hrs ago</time>
    </li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-03-29T22:34:00-04:00">
    <meta itemprop="datePublished" content="2021-03-29T22:34:00-04:00">
    <meta itemprop="dateModified" content="2021-03-29T18:40:12-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=James%20McKendree%20Wall&via=waltontribune&url=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.waltontribune.com/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.waltontribune.com/tncms/asset/editorial/7e58a104-9100-11eb-b072-7f4b8c7b3894" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Walton%20Tribune%5D%20James%20McKendree%20Wall&body=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="7e58a104-9100-11eb-b072-7f4b8c7b3894">
                

                <div class="row">
                    <div class="col-lg-8 col-md-12 col-sm-8 col-lg-push-4 col-md-push-0 col-sm-push-4" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=James%20McKendree%20Wall&via=waltontribune&url=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.waltontribune.com/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.waltontribune.com/tncms/asset/editorial/7e58a104-9100-11eb-b072-7f4b8c7b3894" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Walton%20Tribune%5D%20James%20McKendree%20Wall&body=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7e58a104-9100-11eb-b072-7f4b8c7b3894-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7e58a104-9100-11eb-b072-7f4b8c7b3894" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7e58a104-9100-11eb-b072-7f4b8c7b3894" class="save-list-7e58a104-9100-11eb-b072-7f4b8c7b3894-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7e58a104-9100-11eb-b072-7f4b8c7b3894" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>James McKendree Wall, 92, a longtime resident of Elmhurst, Illinois, passed away Monday, March 22, 2021.</p><p>He was born on Oct. 27, 1928, in Monroe to Louie David Wall and Lida Day Wall. After graduating high school, he enrolled at Georgia Tech and became a sportswriter for The Atlanta Journal and The Atlanta Constitution. He graduated from Emory University with a degree in journalism, just before the Korean Conflict. He enrolled in the United States Air Force and served in Alaska Command. He received his Master of Divinity from Emory University and an Master of Arts from the University of Chicago. He was ordained a minister in the United Methodist Church in 1955. He traveled to the Middle East more than 20 times, which influenced his many years of writing about the injustice to which the Palestinians were being subjected.</p><p>He edited the United Methodists’ Christian Advocate from 1962-1972. Subsequently, he served as editor and publisher of The Christian Century in Chicago from 1972 through February 1999. The Century was considered the flagship magazine of U.S. mainline Protestantism. From 1999 through 2008, he wrote a column for the Christian Century, while serving as senior contributing editor. He was a contributing editor from 2008 until July 2017.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Wall served as a member of a Bioethics Policy Task Force for the National Aeronautics and Space Administration from 1994 through early 1996. He also served on a special committee of the National Academy of Science that, at the request of the Centers for Disease Control and Prevention, monitored dose reconstruction studies at nuclear weapons processing sites. He was a member of the Program Review Committee for Battelle Memorial Institute, which monitored a program that identified a permanent location for the nation’s high-level nuclear waste disposal site, and was a member of a special committee of the National Academy of Science that produced a 1988 report on the use of animals in biomedical research.</p><p>He was active in the Democratic Party, serving in a variety of roles. Wall was chair of the Jimmy Carter presidential primary and general election campaigns in Illinois in 1976 and 1980 and a delegate for Carter at the 1976 and 1980 Democratic National Conventions. He served a term on the Democratic National Committee and was an unsuccessful candidate for the House of Representatives in 1972. Also, that year, Wall was an organizer and chair of George McGovern’s Illinois delegates to the Democratic National Convention.</p><p>In 1983-84, Wall took a six-month leave from the Christian Century to manage Rep. Paul Simon’s successful primary campaign for a U.S. Senate seat from Illinois.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle-asset', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p>He was the beloved husband of Mary Eleanor Wall since 1953; father of David McKendree (Robin) Wall, Robert Kidder (Renae) Wall and Richard James Wall; grandfather of Rachel Micelle (Jesse) Welliver, Adam McKendree (Kimmie) Wall, Melissa Grace Wall and Mariah (Carlen) Cyphers; great-grandfather of Norah Ruth Welliver, Lydia Noelle Welliver, Clara Eden Welliver and Chance McKendree Wall and brother of Louie D. Wall Jr. and Hughes Wall.</p><p>A visitation will be held from 1-5 p.m. CDT Thursday, April 1, at Elmhurst Community Funeral Home – THE AHLGRIM CHAPEL, 567 S. Spring Road, Elmhurst, IL 60126.</p><p>A memorial service will be held at a future date at First United Methodist Church of Elmhurst.</p><p>Interment will be private.</p><p>Memorial contributions in his name may be made to Seraj Library Project, 636 N. Harvey Ave., Oak Park, IL 60302; First United Methodist Church of Elmhurst, 232 S. York Road, Elmhurst, IL 60126; or the DuPage Foundation, 3000 Woodcreek Drive Suite 310, Downers Grove, IL 60515-5408.</p><p>For additional information: 630-834-3515 or <a href="http://www.ElmhurstFH.com">www.ElmhurstFH.com</a>.</p><div class="tnt-tribute panel panel-default">
                <div class="panel-body">
                    <strong>To plant a tree <span class="tnt-tribute-name">in memory of James Wall</span> as a living tribute, please visit <a href="https://tree.tributecenterstore.com/?oId=20510974&amp;source=tn16" class="tnt-tribute-link" target="_blank" rel="nofollow noopener">Tribute Store</a>.</strong>
                </div>
            </div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
                                <div class="asset-tagline text-muted"><p>The Walton Tribune | Wednesday, March 31, 2021</p></div>
                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=James%20McKendree%20Wall&via=waltontribune&url=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.waltontribune.com/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.waltontribune.com/tncms/asset/editorial/7e58a104-9100-11eb-b072-7f4b8c7b3894" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Walton%20Tribune%5D%20James%20McKendree%20Wall&body=https%3A%2F%2Fwww.waltontribune.com%2Fobituaries%2Farticle_7e58a104-9100-11eb-b072-7f4b8c7b3894.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/article_7e58a104-9100-11eb-b072-7f4b8c7b3894.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7e58a104-9100-11eb-b072-7f4b8c7b3894"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7e58a104-9100-11eb-b072-7f4b8c7b3894-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7e58a104-9100-11eb-b072-7f4b8c7b3894" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7e58a104-9100-11eb-b072-7f4b8c7b3894" class="save-list-7e58a104-9100-11eb-b072-7f4b8c7b3894-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7e58a104-9100-11eb-b072-7f4b8c7b3894" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div><div class="col-lg-4 col-md-12 col-sm-4 col-md-pull-0 col-sm-pull-8 col-lg-pull-8" data-subscription-required-remove>
                            <aside class="related-sidebar default  subscriber-hide">

                                

                                <div id="tncms-region-article_aside_top" class="tncms-region hidden-print"></div>

                                
                                

                                
                                    <div class="asset-map">
                                        <div id="google-map-container-7e58a104-9100-11eb-b072-7f4b8c7b3894" class="map-canvas multi-location" style="min-height:220px;"></div>
                                    </div>
                                

                                

                                

                                

                                

                                

                                

                                

                                

                                

                                <div id="tncms-region-article_aside_bottom" class="tncms-region hidden-print"></div>

                                

                                <div id="article-aside-sticky-spacer"><div id="tncms-region-article_aside_sticky" class="tncms-region hidden-print"></div></div>

                            </aside>
                        </div></div><!-- /asset-content -->

                <div id="asset-below">
                    <div class="asset-tribute-events">
        </div>

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1801178" class="tncms-block most-pop-block"><section id="block-1801178" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1801178 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1801178" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1801178" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1801178" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-1801178" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1801178" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/news/article_46f63df0-8fc2-11eb-a216-d33f566f93ef.html">Pedestrian killed in Loganville</a></li><li><a href="/news/article_20410eec-8d65-11eb-a560-9ffbb20ad310.html">Police continue to investigate child cruelty case</a></li><li><a href="/news/article_f78c39e8-8bea-11eb-bb74-eb2e5fbdb128.html">Monroe to discuss 'calming' measures</a></li><li><a href="/news/article_0b059742-8e77-11eb-93ea-8fb73c4db53a.html">Keep calm and motor on</a></li><li><a href="/news/article_96860a34-8f41-11eb-87d4-c36cab9bd079.html">Fire contained before spreading to woods, neighbors</a></li><li><a href="/news/article_96df7672-8ccc-11eb-85a1-7399d1e4deb5.html">GDOT sets up detour after crash</a></li><li><a href="/article_29b6eb58-8e79-11eb-96bc-6b1e9d739a07.html">Walton County to open mass vaccination site Wednesday</a></li><li><a href="/article_e72cda72-8824-11eb-8ba4-8b117c56e73a.html">Passerby finds missing DeKalb toddler</a></li><li><a href="/article_fdaec91c-8dc5-11eb-a520-8fefc0eeed6b.html">Tornado watch issued for Thursday night into Friday morning</a></li><li><a href="/article_55eabf5e-8be7-11eb-a507-cfec1a89bf4f.html">Friends, family, police looking for answers</a></li></ul></div>
        
        
            <div id="images-1801178" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/image_d4266566-8be8-11eb-a1f4-5be16ca68a1d.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Suspect Enters"
                            class="img-responsive lazyload full default"
                            width="1000"
                            height="1000"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/d/42/d4266566-8be8-11eb-a1f4-5be16ca68a1d/605a0324405d7.image.jpg?crop=1000%2C1000%2C0%2C134&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/d/42/d4266566-8be8-11eb-a1f4-5be16ca68a1d/605a0324405d7.image.jpg?crop=1000%2C1000%2C0%2C134&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/d/42/d4266566-8be8-11eb-a1f4-5be16ca68a1d/605a0324405d7.image.jpg?crop=1000%2C1000%2C0%2C134&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/d/42/d4266566-8be8-11eb-a1f4-5be16ca68a1d/605a0324405d7.image.jpg?crop=1000%2C1000%2C0%2C134&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/d/42/d4266566-8be8-11eb-a1f4-5be16ca68a1d/605a0324405d7.image.jpg?crop=1000%2C1000%2C0%2C134&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/d/42/d4266566-8be8-11eb-a1f4-5be16ca68a1d/605a0324405d7.image.jpg?crop=1000%2C1000%2C0%2C134&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/d/42/d4266566-8be8-11eb-a1f4-5be16ca68a1d/605a0324405d7.image.jpg?crop=1000%2C1000%2C0%2C134&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/d/42/d4266566-8be8-11eb-a1f4-5be16ca68a1d/605a0324405d7.image.jpg?crop=1000%2C1000%2C0%2C134&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/d/42/d4266566-8be8-11eb-a1f4-5be16ca68a1d/605a0324405d7.image.jpg?crop=1000%2C1000%2C0%2C134&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/d/42/d4266566-8be8-11eb-a1f4-5be16ca68a1d/605a0324405d7.image.jpg?crop=1000%2C1000%2C0%2C134&resize=1000%2C1000&order=crop%2Cresize 1035w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/image_b6914d30-86a3-11eb-9123-dfe987339d13.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Olivia Ware"
                            class="img-responsive lazyload full default"
                            width="200"
                            height="200"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/b/69/b6914d30-86a3-11eb-9123-dfe987339d13/60512bc92d6c2.image.jpg?crop=200%2C200%2C0%2C50&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/b/69/b6914d30-86a3-11eb-9123-dfe987339d13/60512bc92d6c2.image.jpg?crop=200%2C200%2C0%2C50&resize=200%2C200&order=crop%2Cresize 200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/image_1628056e-89f0-11eb-909e-13a384e7dab5.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Shooting Suspect"
                            class="img-responsive lazyload full default"
                            width="703"
                            height="703"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/1/62/1628056e-89f0-11eb-909e-13a384e7dab5/6056b45ad2f59.image.jpg?crop=703%2C703%2C98%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/1/62/1628056e-89f0-11eb-909e-13a384e7dab5/6056b45ad2f59.image.jpg?crop=703%2C703%2C98%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/1/62/1628056e-89f0-11eb-909e-13a384e7dab5/6056b45ad2f59.image.jpg?crop=703%2C703%2C98%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/1/62/1628056e-89f0-11eb-909e-13a384e7dab5/6056b45ad2f59.image.jpg?crop=703%2C703%2C98%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/1/62/1628056e-89f0-11eb-909e-13a384e7dab5/6056b45ad2f59.image.jpg?crop=703%2C703%2C98%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/1/62/1628056e-89f0-11eb-909e-13a384e7dab5/6056b45ad2f59.image.jpg?crop=703%2C703%2C98%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/1/62/1628056e-89f0-11eb-909e-13a384e7dab5/6056b45ad2f59.image.jpg?crop=703%2C703%2C98%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/1/62/1628056e-89f0-11eb-909e-13a384e7dab5/6056b45ad2f59.image.jpg?crop=703%2C703%2C98%2C0&resize=703%2C703&order=crop%2Cresize 750w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/image_56fff8f4-8bed-11eb-a68c-77570269eb4c.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Republicans Gather"
                            class="img-responsive lazyload full default"
                            width="861"
                            height="861"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/5/6f/56fff8f4-8bed-11eb-a68c-77570269eb4c/605a0ab9d439b.image.jpg?crop=861%2C861%2C477%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/5/6f/56fff8f4-8bed-11eb-a68c-77570269eb4c/605a0ab9d439b.image.jpg?crop=861%2C861%2C477%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/5/6f/56fff8f4-8bed-11eb-a68c-77570269eb4c/605a0ab9d439b.image.jpg?crop=861%2C861%2C477%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/5/6f/56fff8f4-8bed-11eb-a68c-77570269eb4c/605a0ab9d439b.image.jpg?crop=861%2C861%2C477%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/5/6f/56fff8f4-8bed-11eb-a68c-77570269eb4c/605a0ab9d439b.image.jpg?crop=861%2C861%2C477%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/5/6f/56fff8f4-8bed-11eb-a68c-77570269eb4c/605a0ab9d439b.image.jpg?crop=861%2C861%2C477%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/5/6f/56fff8f4-8bed-11eb-a68c-77570269eb4c/605a0ab9d439b.image.jpg?crop=861%2C861%2C477%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/5/6f/56fff8f4-8bed-11eb-a68c-77570269eb4c/605a0ab9d439b.image.jpg?crop=861%2C861%2C477%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/waltontribune.com/content/tncms/assets/v3/editorial/5/6f/56fff8f4-8bed-11eb-a68c-77570269eb4c/605a0ab9d439b.image.jpg?crop=861%2C861%2C477%2C0&resize=861%2C861&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1801178" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-1801178" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc "><li><a href="/business/article_0126733e-875d-11eb-9791-076ad53806b2.html">New retailers announced for Monroe Pavilion</a> (3)</li><li><a href="/news/article_d63a77ca-85c6-11eb-856d-bbbb5254f98c.html">Plane makes emergency landing in Bold Springs</a> (2)</li><li><a href="/news/article_2b3076c6-8734-11eb-90f7-8b1691e948ac.html">Suspect cites sex addiction, not race</a> (1)</li><li><a href="/opinion/article_7cc577ac-7dfc-11eb-883b-57b9ba191237.html">Our View: Making the right call on Dr. Seuss</a> (1)</li><li><a href="/sports/article_ab84eb32-8e68-11eb-9478-b789baf42bb7.html">Baseball: Redskins on a roll in Region 8-A Public play</a> (1)</li><li><a href="/news/article_b43001d4-7baf-11eb-afee-a70acfee7cda.html">Youth Middle sees rise in COVID-19 cases</a> (1)</li><li><a href="/news/article_bc08c10a-81f1-11eb-bb0e-db58da0819a5.html">Trump encourages Herschel Walker to run for Senate</a> (1)</li><li><a href="/sports/article_c9411d8c-8100-11eb-9cbc-7f313e8a61ed.html">Baseball: ’Skins still growing up</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-1801139" class="tncms-block visible-lg visible-md"><section id="block-1801139" class="block emphasis-h4 dark  " ><div class="clearfix">
    
    <div class="block-title title-1801139 ">
        <div class="block-title-inner">
            <h4>
                
                Latest News
                
            </h4>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-square border border-dashed"><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/article_cf7f8d8e-910c-11eb-a56b-5bb5ea91f51a.html" class="tnt-asset-link">
        

        
            Board removes the interim tag for Kevin Little</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/business/article_0b4250ee-90d7-11eb-a22b-33b4ae5315a2.html" class="tnt-asset-link">
        

        
            Blevins earns Alfa honors for production, customer service</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/article_46f63df0-8fc2-11eb-a216-d33f566f93ef.html" class="tnt-asset-link">
        

        
            Pedestrian killed in Loganville</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/article_96860a34-8f41-11eb-87d4-c36cab9bd079.html" class="tnt-asset-link">
        

        
            Fire contained before spreading to woods, neighbors</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/article_0b059742-8e77-11eb-93ea-8fb73c4db53a.html" class="tnt-asset-link">
        

        
            Keep calm and motor on</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/article_1ef6381e-8e78-11eb-86ef-a3aac51f222c.html" class="tnt-asset-link">
        

        
            Senior facilities inch back to normal</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/article_0a0ca144-8e6a-11eb-9cd3-637d120e154e.html" class="tnt-asset-link">
        

        
            For Bugg, a journey from Winder to West Point</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/article_29b6eb58-8e79-11eb-96bc-6b1e9d739a07.html" class="tnt-asset-link">
        

        
            Walton County to open mass vaccination site Wednesday</a></span>
        </li></ul></div>
        </div></div></section></div><div id="tncms-block-1819634" class="tncms-block"><div>
<p><iframe width="300" height="250" src="https://www.youtube.com/embed/N8wANQk78kc" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>

<p><a href="%5B%" ad.tracker_url>Note: Click or tap for more information on <strong>the Student Success Alliance</strong>.</a></p>
</div></div><div id="tncms-block-1884459" class="tncms-block"><section id="block-1884459" class="block emphasis-h3   " ><div id="evvnt-calendar-1884459"></div>
<script defer src="//production-evvnt-plugin-herokuapp-com.global.ssl.fastly.net/evvnt_discovery_plugin_s.js" onload="evvntDiscoveryInit_1884459();"></script></section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1801206" class="tncms-block"></div><div id="tncms-block-1801157" class="tncms-block"></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1801120" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1801121" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1801209" class="tncms-block"><section id="block-1801209" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1801209 light">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-news"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-lifestyles"  href="/lifestyles/"  tabindex="0">
                    <span class="nav-label">Lifestyles</span>
                </a></li><li>
                <a class="nav-link   tnt-section-education"  href="/education/"  tabindex="0">
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link   tnt-section-communities"  href="/communities/"  tabindex="0">
                    <span class="nav-label">Communities</span>
                </a></li><li>
                <a class="nav-link   tnt-section-opinions"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinions</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-local-events"  href="/local-events/"  tabindex="0">
                    <span class="nav-label">Local Events</span>
                </a></li><li>
                <a class="nav-link   tnt-section-photo-galleries"  href="/multimedia/photos/"  tabindex="0">
                    <span class="nav-label">Photo Galleries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-video-gallery"  href="/multimedia/videos/"  tabindex="0">
                    <span class="nav-label">Video Gallery</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather/"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link   tnt-section-loganville-tribune"  href="/loganville/"  tabindex="0">
                    <span class="nav-label">Loganville Tribune</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1801169" class="tncms-block"><section id="block-1801169" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1801169 light">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-staff"  href="/site/staff.html"  tabindex="0">
                    <span class="nav-label">Staff</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertise-with-us"  href="/advertise/"  tabindex="0">
                    <span class="nav-label">Advertise With Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-rack-locations"  href="/rack_locations/"  tabindex="0">
                    <span class="nav-label">Rack Locations</span>
                </a></li><li>
                <a class="nav-link   tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=WALTONTRIBUNE&amp;publisher_url:waltontribune.com#/quick"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Promote Your Event</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-an-ad"  href="/site/forms/online_services/classified/"  tabindex="0">
                    <span class="nav-label">Place An Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services/subscribe/"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-forms"  href="/site/forms/"  tabindex="0">
                    <span class="nav-label">Forms</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1801211" class="tncms-block"><section id="block-1801211" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1801211 light">
        <div class="block-title-inner">
            <h4>
                
                The Walton Tribune
                
            </h4>
        </div>
    </div></div><address>
    <strong>WaltonTribune.com</strong><br>
    121 S. Broad St.<br>
    Monroe, GA 30655
    <br>
    
        <strong>Phone:</strong> 770-267-8371<br>
        <strong>Email:</strong> <a href="mailto:support@waltontribune.com">support@waltontribune.com</a><br>
    
</address></section></div><div id="tncms-block-1801219" class="tncms-block padding-bottom"><div class="follow-links-1801219 default">
    
    <section id="block-1801219" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="http://facebook.com/waltontribune" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.twitter.com/waltontribune" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/user/TheTribunetube" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://instagram.com/thewaltontribune" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.waltontribune.com",
  "sameAs" : ["http://facebook.com/waltontribune","https://www.twitter.com/waltontribune","https://www.youtube.com/user/TheTribunetube","https://instagram.com/thewaltontribune"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "><div id="tncms-block-1801173" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1801173"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">The Walton Tribune</a>, 121 S. Broad St. Monroe, GA</small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "></div>
        </div>
    </div>
    
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/waltontribune.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("7e58a104-9100-11eb-b072-7f4b8c7b3894")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc14694.add('act', dmpData);_cc14694.bcp();
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script src="https://maps.googleapis.com/maps/api/js?v=3&amp;key=AIzaSyDX86PUJZ4-tBlpoCmqSY9jtk8_Q_wabTM"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/waltontribune.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.map.google.e92e2ae67358c304fe70eaaeff0324f2.js"></script>
<script>/*<![CDATA[*/ var map7e58a104910011ebb0727f4b8c7b3894 = new __tnt.map.google({
            id: '7e58a104-9100-11eb-b072-7f4b8c7b3894',
            locations: [{"address":"567 S Spring Rd, Elmhurst, IL 60126","lat":"","lon":"","icon_fill":"#EA4335","icon_classes":[],"label":null}],
            map_id: 'google-map-container-7e58a104-9100-11eb-b072-7f4b8c7b3894',
            icon_fill: null,
            draggable_mobile: false,
            street_view: true,
            use_latlng: false
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ function evvntDiscoveryInit_1884459() {
        evvnt_require("evvnt/discovery_plugin").init({
            publisher_id: "waltontribune.com",
            discovery: {
                element: "#evvnt-calendar-1884459",
                detail_page_enabled: true,
                widget: true,
                virtual: false,
                map: false,
                category_id: null, 
                orientation: "portrait",
                number: 3,
            },
            submission: {
                partner_name: "Walton Tribune",
                text: "Promote your event",
            }
        });
    } /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc14694.add('act', serviceData);_cc14694.bcp();
                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc14694.add('act', dmpData);_cc14694.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>